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1 INTRODUCTION 

This document consists of annotated example of the Common Metadata Media Manifest 

as used for delivery.   

These are based on two documents: Common Metadata Media Manifest and Using Media 

Manifest, File Manifest and Avails for file Delivery (Best Practice).  The applicable 

specifications and example files can be found at www.movielabs.com/md/manifest.  Also useful 

for reference is Common Metadata, found at www.movielabs.com/md/md.  

Examples are based on document versions at the time of writing, although they should 

also apply to later versions as well. 

1.1 Document Organization 

This document is organized by the top-level elements being documented, starting from 

the right in the following illustration.  
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1.2 Examples used in this document 

Examples are drawn from the following examples.  

NOTE:  These examples can be used as templates to build Media Manifests, however the 

contents remains the property of the respective rights holders. 

 Boondock Saints II, subbed, Japanese 

 Boondock Saints II, dubbed, Japanese 

 Boondock Saints II, non-Japanese 

 Bad Words 

 The Counselor, regular 

 The Counselor, extended 

 Frozen, US, dubbed 

 Frozen, SK, dubbed 

These are not necessarily final versions.  They are included for illustrative purposes only.   

1.3 Document Conventions 

The following conventions are used in this document: 

{SNIP} means something has been removed.  Sometimes a comment is included. For 

example: {SNIP: basic metadata}. 

{n} is used to reference a point in the data where n is numerical reference; for example, 

{1} 

“HINT” is used to present suggestions, particularly where there might be confusion. 

“OOPS” indicates there is a problem in the example.  These are highlighted to illustrate 

common errors. 
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2 MANIFEST STRUCTURE 

This collection of examples shows that there are many correct ways to build a Media 

Manifest.  The following paragraphs provide an overview of the examples, providing some 

context for why they were written as they are.  To the best of my knowledge, these are all valid. .  

Each example addresses the specific realities of each organization delivering the content. 

Boondock Saints II addresses a difficult internationalization problem.  First, it handles 

burned in subs and separate subtitle tracks.  Also, the tracks were not conformed so they cannot 

be delivered in a single Presentation.  The result is three manifests:  Japanese Subbed, Japanese 

Dubbed, and non-Japanese.  Subbed and Dubbed are distinct because they have different 

subtitles burned into the video (dubbed only forced subtitles).  There was no guarantee that the 

tracks could be reused between these three, so three manifests were in order.  If, however, tracks 

could be reused, it would be preferable to package them into a single manifest with a single 

Inventory.  The Experiences all contain main feature and a preview.  There are different 

Presentations for each language (JP, EN, ES, KO).  Going forward, it would be nice to see if all 

tracks that can be conformed. They can all then be in the same Presentation, greatly simplifying 

the Manifest. 

Bad Words packs a full set of international tracks into on Media Manifest, also in 

accordance with the Manifest’s intended design.  Internationalized metadata is included for 

multiple languages.  Even the ratings are internationalized.  The authors chose to create separate 

Audiovisual for each language; although, it might have been preferable to have distinct 

experiences because language is captured in the Experience definition making it easier to 

differentiate tracks.  Note that even with multiple Experiences, metadata need only to be 

included once, so it would not have made the Manifest much longer.  The use of Manifest IDs in 

this Manifest is excellent (although EIDR is preferred). 

The Counselor has regular and extended versions.  As these are likely distinct product 

offerings, it makes sense to separate them.  These are nicely internationalized, containing a full 

set of tracks and metadata.  In the Experience, the authors made full use of Playable Sequences, 

showing all the dub cards in sequence after the main feature.  All tracks are collected in two 

presentations; one for the main feature and one for the trailer.  From here, it’s just a matter of 

specifying the where the tracks can be found.  This is a simple and elegant Manifest. 

Frozen includes manifests for US and Slovakia (SK).  These demonstrate how a simple 

configuration yields a simple Manifest.  Excluding metadata, the entire Manifest is about a page, 

but still contains both a main feature and a trailer.  The authors use a Playable Sequence for dub 

cards in Slovakia.  Beyond that, it contains three Presentations for Slovakia (main, trailer and 

dub cards) and two for the US (main, trailer) and the associated track definitions in the 

Inventory. 
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3 EXPERIENCE 

3.1 Frozen 

This is as simple as it gets.  There is one Audiovisual for the main title and one for the 

trailer. IDs are based on EIDR and properly formed. 

<manifest:Experiences> 

 <manifest:Experience ExperienceID="md:experienceid:mpm:750000029502:google.frozen.th.experience.en.us_dub" 

version="1.0"> 

  <manifest:BasicMetadata ContentID="md:cid:mpm:750000029502"> {SNIP: Basic metadata} </manifest:BasicMetadata> 

  <manifest:Audiovisual ContentID="md:cid:mpm:750000029502"> {1} 

   <manifest:Type>Main</manifest:Type> 

   <manifest:PresentationID> 

md:presentationid:mpm:750000029502:google.frozen.th.feature.presentation.en.us_dub</manifest:PresentationID> 

  </manifest:Audiovisual> 

  <manifest:Audiovisual ContentID="md:cid:mpm:750000029502"> {2} 

   <manifest:Type>Promotion</manifest:Type> 

   <manifest:PresentationID> 

md:presentationid:mpm:750000029502:google.frozen.all.promotion.presentation.en.us_dub</manifest:PresentationID> 

  </manifest:Audiovisual> 

 </manifest:Experience> 

</manifest:Experiences> 

The following example, also from Frozen, is similar to the example above with one 

important distinction:  Rather than referencing a Presentation, it references a Playable Sequence 

{1} that adds the dubbing credits to the video.  This allows the same video asset to be used with 

a different audio track and a dubbing clip. The trailer {2} doesn’t have a dubbing credits, so a 

simple Presentation works here. 

<manifest:Experiences> 

 <manifest:Experience ExperienceID="md:experienceid:mpm:750000029502:google.frozen.th.experience.sk.slovakia_dub" 

version="1.0"> 

  <manifest:BasicMetadata ContentID="md:cid:mpm:750000029502"> 

  </manifest:BasicMetadata> 

  <manifest:Audiovisual ContentID="md:cid:mpm:750000029502"> 

   <manifest:Type>Main</manifest:Type> 

 <manifest:PlayableSequenceID>md:playablesequenceid:mpm:750000029502:google.frozen.th.featurewithdubcard.playablesequen

ce.sk.slovakia_dub</manifest:PlayableSequenceID> {1} 

  </manifest:Audiovisual> 

  <manifest:Audiovisual ContentID="md:cid:mpm:750000029502"> 

   <manifest:Type>Promotion</manifest:Type> 

 <manifest:PresentationID>md:presentationid:mpm:750000029502:google.frozen.all.promotion.presentation.sk.slovakia_dub</mani

fest:PresentationID> {2} 

  </manifest:Audiovisual> 

 </manifest:Experience> 

</manifest:Experiences> 
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3.2 The Councelor 

In this case, the Experience is simple with one Audiovisual for the main title and one for 

the trailer.  In this case, however, the referenced Presentations contain multiple languages.  So, 

the user experience behind these Experiences is very International.  IDs are based on EIDR and 

properly formed. 

HINT: The Content ID used for the trailer {2} is the same as the main title.  This is a 

reasonable practice since there probably isn’t trailer metadata. However, it’s preferred to have 

metadata for the trailer. 

<manifest:Experiences> 

 <manifest:Experience ExperienceID="md:experienceid:eidr-x:28BC-9082-7FBD-3972-19DC-H:experience" version="1.0"> 

  <manifest:BasicMetadata ContentID="md:cid:eidr-s:28BC-9082-7FBD-3972-19DC-H"> {SNIP: Basic metadata} 

  </manifest:BasicMetadata> 

  <manifest:Audiovisual ContentID="md:cid:eidr-s:28BC-9082-7FBD-3972-19DC-H"> {1} 

   <manifest:Type>Main</manifest:Type> 

   <manifest:SubType>Feature</manifest:SubType> 

   <manifest:PlayableSequence> 

    <manifest:Clip sequence="0"> 

     <manifest:PresentationID> 

md:presentationid:eidr-x:28BC-9082-7FBD-3972-19DC-H:feature.presentation</manifest:PresentationID> 

    </manifest:Clip> 

   </manifest:PlayableSequence> 

  </manifest:Audiovisual> 

  <manifest:Audiovisual ContentID="md:cid:eidr-s:28BC-9082-7FBD-3972-19DC-H"> {2} 

   <manifest:Type>Promotion</manifest:Type> 

   <manifest:PresentationID> 

md:presentationid:eidr-x:28BC-9082-7FBD-3972-19DC-H:trailer.en.presentation</manifest:PresentationID> 

  </manifest:Audiovisual> 

  <manifest:Audiovisual ContentID="md:cid:eidr-s:28BC-9082-7FBD-3972-19DC-H"> 

   <manifest:Type>Promotion</manifest:Type> 

   <manifest:PresentationID>md:presentationid:eidr-x:28BC-9082-7FBD-3972-19DC-

H:preview.presentation</manifest:PresentationID> 

  </manifest:Audiovisual> 

 </manifest:Experience> 

</manifest:Experiences> 

3.3 Boondock Saints II 

Boondock Saints II, subbed  

<manifest:Experiences> 

        <manifest:Experience ExperienceID="eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.01" version="1.0"> 

            <manifest:Region> 

                <md:country>JP</md:country> {1} 

            </manifest:Region> 

            <manifest:BasicMetadata ContentID="urn:dece:cid:eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.01.metadata"> {SNIP: 

Basic metadata}  </manifest:BasicMetadata> {2} 

            <manifest:Audiovisual ContentID="urn:dece:cid:eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.01.main.01">{5} 

                <manifest:Type>Main</manifest:Type> {3} 
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                <manifest:PresentationID>eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:feature.presentation.01</manifest:PresentationID> 

            </manifest:Audiovisual> 

            <manifest:Audiovisual ContentID="urn:dece:cid:eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.01.preview.en-US.ja-

JP">{6} 

                <manifest:Type>Promotion</manifest:Type> {4} 

                <manifest:PresentationID>eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:preview.presentation.en-US.ja-

JP</manifest:PresentationID> 

            </manifest:Audiovisual> 

        </manifest:Experience> 

    </manifest:Experiences> 

Boondock Saints II, dubbed is almost identical to the subbed version, but the referenced 

presentations are different.  

manifest:Experiences> 

        <manifest:Experience ExperienceID="eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.03" version="1.0"> 

            <manifest:Region> 

                <md:country>JP</md:country> 

            </manifest:Region> 

            <manifest:BasicMetadata ContentID="urn:dece:cid:eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.01.metadata">  

   {SNIP: Basic metadata} </manifest:BasicMetadata> 

            <manifest:Audiovisual ContentID="urn:dece:cid:eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.01.main.01"> 

                <manifest:Type>Main</manifest:Type> 

                <manifest:PresentationID>eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:feature.presentation.01</manifest:PresentationID> 

            </manifest:Audiovisual> 

            <manifest:Audiovisual ContentID="urn:dece:cid:eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:experience.01.preview.ja-JP"> 

                <manifest:Type>Promotion</manifest:Type> 

                <manifest:PresentationID>eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:preview.presentation.ja-JP</manifest:PresentationID> 

            </manifest:Audiovisual> 

        </manifest:Experience> 

    </manifest:Experiences> 

3.3.1 IDs 

HINT: Although technically usable, The ExperienceID should be in the form defined in 

Best Practices (3.1.7).  It’s missing the prefix ‘urn:dece:experienceid:’ or ‘md:experienceid’.  

The same is true for Presentation IDs.   

Subs and Dubs used the same Experience ID, but that is corrected here. 

3.3.2 Region and Language 

This Experience is designed for Japan as can be seen by the Region {1}.   

3.3.3 Metadata 

The author chose to present metadata specific to Japan {2}.  The ‘eidr-x’ syntax is used 

to capture the EIDR and to distinguish the specific metadata used in this Experience. 
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HINT: The type of identifier is included in the standard urn:dece and md: forms.  We 

know the identifier in {2} is a Content ID because of the form urn:dece:cid.  Because the type is 

known, the ‘.metadata’ at the end of the identifier is unnecessary.   

HINT: Common Metadata is designed to support multiple localizations, using multiple 

LocalizedInfo elements.  If you have multiple localizations available, you can include them all in 

the same metadata.  This is particularly useful if you include metadata by reference (see next 

hint).  Boondock Saints II, non-Japanese version is an excellent example of metadata serving 

multiple languages: Latin American Spanish, Korean, Quebecois and English. One improvement 

to this set is to include localized DisplayName elements for People/Name/DisplayName.  

HINT: Authors have a choice of embedding the metadata in the Experience or 

referencing elsewhere.   

HINT:  Generally for a movie, the metadata for the Audiovisual for the main title matches 

the Experience metadata.  That is, ContentID at {5} would match ContentID at {2}.   OOPS: 

Neither Audiovisual ContentIDs {5} and {6} appear to reference metadata. Without this 

metadata, there is no description for the Audiovisual asset. 

3.3.4 Audiovisual 

There are two Audiovisual presentations: Main and Promotion.  

HINT: More detail can be provided using SubType.  Encoding is documented in Best 

Practices, Section 8.2.  For example, the Main’s SubType could be ‘Feature’ and the Promotion’s 

SubType might be ‘Trailer’.   

3.3.5 Variations 

There are three version of Boondock Saints II:  Japanese Subbed, Japanese Dubbed and 

“non-Japan”.  This is how the studio chose to package this title.  The Subbed versions have 

subtitles burned into the video, while the Dubbed version does not.   

The metadata for the subbed and dubbed are the same. 

The Experiences differ in that they reference different tracks. 

HINT:  You might be asking yourself if this must be three files.  It depends.  The most 

general design is to combine them in one.  There would be one metadata set that covered both 

the Japanese and non-Japanese languages. 
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4 PLAYABLE SEQUENCE AND PRESENTATION 

4.1 Frozen 

This example shows three presentations {1} and {2} and {3}, and a Playable Sequence 

{4}.   

The way this is configured the Playable Sequence plays the main title {4a} and the dub 

card {4b}. 

The first Presentation has a video track {1a}, an audio tracks {1b} and subtitle track 

{1c}.    A second Presentation {2} has a single video track and a single audio track.   The third 

Presentation {3} is a dub card, so it only has video. 

<manifest:Presentations> 

 <manifest:Presentation {1} 

PresentationID="md:presentationid:mpm:750000029502:google.frozen.th.feature.presentation.sk.slovakia_dub"> 

  <manifest:TrackMetadata> 

   <manifest:TrackSelectionNumber>0</manifest:TrackSelectionNumber> 

   <manifest:VideoTrackReference> {1a} 

 <manifest:VideoTrackID>md:vidtrackid:mpm:750000029502:google.frozen.th.video.en.pseudotextless</manifest:VideoTrackID> 

   </manifest:VideoTrackReference> 

   <manifest:AudioTrackReference> {1b} 

   <manifest:AudioTrackID>md:audtrackid:mpm:750000029502:google.frozen.th.primary.audio.sk.8ch</manifest:AudioTrackID> 

   </manifest:AudioTrackReference> 

   <manifest:SubtitleTrackReference>{1c} 

    <manifest:SubtitleTrackID>md:subtrackid:mpm:750000029502:google.frozen.th.sk.narrative</manifest:SubtitleTrackID> 

   </manifest:SubtitleTrackReference> 

  </manifest:TrackMetadata> 

 </manifest:Presentation> 

 <!-- Presentation: Promo --> 

 <manifest:Presentation {2} 

PresentationID="md:presentationid:mpm:750000029502:google.frozen.all.promotion.presentation.sk.slovakia_dub"> 

  <manifest:TrackMetadata> 

   <manifest:TrackSelectionNumber>0</manifest:TrackSelectionNumber> 

   <manifest:VideoTrackReference> 

 <manifest:VideoTrackID>md:vidtrackid:mpm:750000029502:google.frozen.all.promotion.video.sk.trailerdub</manifest:VideoTrac

kID> 

   </manifest:VideoTrackReference> 

   <manifest:AudioTrackReference> 

 <manifest:AudioTrackID>md:vidtrackid:mpm:750000029502:google.frozen.all.promotion.video.sk.trailerdub</manifest:AudioTrac

kID> 

   </manifest:AudioTrackReference> 

  </manifest:TrackMetadata> 

 </manifest:Presentation> 

 </manifest:Presentations> 

 <!-- Presentation: Dubcard --> 

 <manifest:Presentation {3} 

PresentationID="md:presentationid:mpm:750000029502:google.frozen.th.dubcard.presentation.sk.slovakia_dub"> 

  <manifest:TrackMetadata> 

   <manifest:TrackSelectionNumber>0</manifest:TrackSelectionNumber> 

   <manifest:VideoTrackReference> 

    <manifest:VideoTrackID>md:vidtrackid:mpm:750000029502:google.frozen.th.dubcard.sk.224</manifest:VideoTrackID> 
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   </manifest:VideoTrackReference> 

  </manifest:TrackMetadata> 

 </manifest:Presentation> 

</manifest:Presentations> 

<!--Playable Sequences --> 

<manifest:PlayableSequences> 

 <manifest:PlayableSequence {4} 

PlayableSequenceID="md:playablesequenceid:mpm:750000029502:google.frozen.th.featurewithdubcard.playablesequence.sk.slovakia

_dub"> 

  <manifest:Clip sequence="0"> {4a} 

 <manifest:PresentationID>md:md:presentationid:mpm:750000029502:google.frozen.th.feature.presentation.sk.slovakia_dub</ma

nifest:PresentationID> 

  </manifest:Clip> 

  <manifest:Clip sequence="1"> {4a} 

 <manifest:PresentationID>md:presentationid:mpm:750000029502:google.frozen.th.dubcard.presentation.sk.slovakia_dub</manif

est:PresentationID> 

  </manifest:Clip> 

 </manifest:PlayableSequence> 

</manifest:PlayableSequences> 

4.2 The Counselor 

The Counselor created a Playable Sequence in the Experience.  This is equivalent to 

creating a separate PlayableSequence object and referencing it.  The result of the playable 

sequence is the main feature (Clip sequence=“0”) followed by a series of dub cards (clips 1-8). 

HINT: Track Selection is based on Clip 0.  If other clips have the same tracks, the 

selection will be applied to these tracks.  In this case, the dub cards have no audio or subtitles, so 

just the video plays. 

<manifest:PlayableSequence> 

 <manifest:Clip sequence="0"> 

  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-

G:feature.presentation</manifest:PresentationID> 

 </manifest:Clip> 

 <manifest:Clip sequence="1"> 

  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-G:dubcard.pt-

br.presentation</manifest:PresentationID> 

 </manifest:Clip> 

 <manifest:Clip sequence="2"> 

  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-G:dubcard.fr-

ca.presentation</manifest:PresentationID> 

 </manifest:Clip> 

 <manifest:Clip sequence="3"> 

  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-

G:dubcard.es.presentation</manifest:PresentationID> 

 </manifest:Clip> 

 <manifest:Clip sequence="4"> 

  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-

G:dubcard.de.presentation</manifest:PresentationID> 

 </manifest:Clip> 

 <manifest:Clip sequence="5"> 
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  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-

G:dubcard.it.presentation</manifest:PresentationID> 

 </manifest:Clip> 

 <manifest:Clip sequence="6"> 

  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-G:dubcard.es-

mx.presentation</manifest:PresentationID> 

 </manifest:Clip> 

 <manifest:Clip sequence="7"> 

  <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-

G:dubcard.fr.presentation</manifest:PresentationID> 

 </manifest:Clip> 

  <manifest:Clip sequence="8"> 

   <manifest:PresentationID>md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-

G:dubcard.ru.presentation</manifest:PresentationID> 

 </manifest:Clip> 

</manifest:PlayableSequence> 

The main Presentation includes one video, multiple audio and multiple subtitle tracks.  

Note that each track has a derived ID, based on EIDR and Best Practices, section 3.4.3..  This is 

as good as it gets. 

<manifest:Presentation PresentationID="md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.presentation"> 

 <manifest:TrackMetadata> 

  <manifest:TrackSelectionNumber>0</manifest:TrackSelectionNumber> 

  <manifest:VideoTrackReference> 

   <manifest:VideoTrackID>md:vidtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.video</manifest:VideoTrackID> 

  </manifest:VideoTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.en</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.pt-br</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.fr-ca</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.es</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.de</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.it</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.es-mx</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.fr</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:AudioTrackReference> 

   <manifest:AudioTrackID>md:audtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:feature.audio.ru</manifest:AudioTrackID> 

  </manifest:AudioTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:caption.en</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.pt-br</manifest:SubtitleTrackID> 
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  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.fr-ca</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.es</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.nl-nl</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.nl-be</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.de</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.it</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.ko</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.es-mx</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.fr</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:subtitle.ru</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.pt-br</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.fr-ca</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.es</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.en</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.de</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.it</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.fr</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

  <manifest:SubtitleTrackReference> 

   <manifest:SubtitleTrackID>md:subtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:forced.ru</manifest:SubtitleTrackID> 

  </manifest:SubtitleTrackReference> 

 </manifest:TrackMetadata> 

</manifest:Presentation> 

The other Presentations (dub cards) are all of the same form.   Following is an example.  

Note the proper use of naming conventions for the tracks.  Arguably, the PresentationID does not 



 

Media Manifest 
Examples 

Ref :      TR-META-MMME 
Version:                      v1.2 
Date:  November 24, 2014 

 

Motion Picture Laboratories, Inc. 15 

need the final ‘.presentation’ as that is implicit in ‘md:presentationid’; however, if this increases 

readability, this is fine. 

  <manifest:Presentation PresentationID="md:presentationid:eidr-x:AD07-310C-C59D-6785-C63A-G:dubcard.es.presentation"> 

   <manifest:TrackMetadata> 

    <manifest:TrackSelectionNumber>0</manifest:TrackSelectionNumber> 

    <manifest:VideoTrackReference> 

     <manifest:VideoTrackID>md:vidtrackid:eidr-x:AD07-310C-C59D-6785-C63A-G:dubcard.es</manifest:VideoTrackID> 

    </manifest:VideoTrackReference> 

   </manifest:TrackMetadata> 

  </manifest:Presentation> 
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5 INVENTORY 

The Inventory section needs to include enough information for the Manifest’s recipient to 

figure out where to find the associated tracks.  Because it is so closely tied to the recipients 

extraction process, exactly what is included may vary from company to company.   Regardless, it 

is important that information be provided accurately. 

HINT:  File names are not a substitute for metadata.  File naming is convenient for 

troubleshooting, but the data cannot be processed automatically (this should never be tried). 

HINT: Codec name encoding can be found in Common Metadata, Sections 5.2.31 

(audio), 5.2.5.1 (video) and 5.2.7.3 (subtitles).  OOPS: Some of the metadata is doesn’t follow 

these rules.  The correct entry  for a codec would be “PRORES” or “PCM”. “MOV” is a 

container type found in Section 6.2.1.1, actually encoded “Quicktime (MOV)”. 

HINT: If you’re not sure about metadata and it’s optional, leave it out.  Missing metadata 

is better than incorrect metadata. 

In these examples, all that is needed is the track ID, Type, language and container 

reference (i.e., file name). 

Following are some examples of tracks. 

5.1 Boondock Saints 

This Boondock Saints II example shows appropriate use of metadata.  Codec and picture 

information is correctly included.  The codec is correctly encoded as PRERESHQ, and the 

picture size is included.  Notably, this includes SubtitleLanguage to signal the burned-in subtitle 

language.  

HINT: If subtitles are burned into the video, it’s useful to include SubtitleLanguage.  It’s 

also useful to use the @type attribute to distinguish between language subtitles and forced 

subtitles.  See Common Metadata, sections 5.2.4 (SubtitleLanguage) and 5.2.7.1 (types). 

        <manifest:Video VideoTrackID="eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:preview.video.en-US.ja-

JP.BOONDOCK_SAINTS_II_THE_ALL_SAINTS_DAY_2009_HE_DC_EXT_GoogleV2_LOCJP_SUBBED-preview-JP.mov"> 

            <md:Type>primary</md:Type> 

            <md:Encoding> 

                <md:Codec>PRORESHQ</md:Codec> 

            </md:Encoding> 

            <md:Picture> 

                <md:AspectRatio>16:9</md:AspectRatio> 

                <md:WidthPixels>1920</md:WidthPixels> 

                <md:HeightPixels>1080</md:HeightPixels> 

            </md:Picture> 

            <md:SubtitleLanguage>ja-JP</md:SubtitleLanguage> 

            <manifest:ContainerReference> 
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<manifest:ContainerLocation>file://resources/BOONDOCK_SAINTS_II_THE_ALL_SAINTS_DAY_2009_HE_DC_EXT_GoogleV2_

LOCJP_SUBBED-preview-JP.mov</manifest:ContainerLocation> 

            </manifest:ContainerReference> 

From the same Manifest, here is an audio example.  It’s pretty straightforward and typical 

of an Audio element.  Note that the codec is correctly encoded. 

HINT: It’s best to use the @dubbed attribute of Language to indicate whether or not the 

track is original audio.  However, this does not necessarily apply to animated pictures as the 

animation is not necessarily specific to a language. 

<manifest:Audio AudioTrackID="eidr-x:0A4A-3282-11B4-F1C9-0A7E-U:feature.audio.ja-

JP.BOONDOCK_SAINTS_II_THE_ALL_SAINTS_DAY_2009_HE_DC_EXT_GoogleV2_LOCJP_DUBBED-source.mov"> 

       <md:Type>primary</md:Type> 

       <md:Encoding> 

           <md:Codec>PCM</md:Codec> 

       </md:Encoding> 

       <md:Language>ja-JP</md:Language> 

       <manifest:ContainerReference> 

         <manifest:ContainerLocation> 

file://resources/BOONDOCK_SAINTS_II_THE_ALL_SAINTS_DAY_2009_HE_DC_EXT_GoogleV2_LOCJP_DUBBED-

source.mov</manifest:ContainerLocation> 

      </manifest:ContainerReference> 

</manifest:Audio> 

5.2 Bad Words 

The following example, show the use of @dubbed. The English track is not dubbed and 

the Czech track is dubbed. 

<manifest:Audio AudioTrackID="md:audtrackid:org:nbcu.com-x:04077_BadWords.trailer.audio.2.en-US"> 

      <md:Type>primary</md:Type> 

      <md:Language dubbed="false">en-US</md:Language> 

      <manifest:ContainerReference> 

        <manifest:ContainerLocation> 

file://resources/BadWords_MLNA_HD240_8Ch_Trailer_V1_JF_JF.mov</manifest:ContainerLocation> 

      </manifest:ContainerReference> 

    </manifest:Audio> 

    <manifest:Audio AudioTrackID="md:audtrackid:org:nbcu.com-x:04077_BadWords.feature.audio.3.cs"> 

      <md:Type>primary</md:Type> 

      <md:Language dubbed="true">cs</md:Language> 

      <manifest:ContainerReference> 

        <manifest:ContainerLocation> 

file://resources/badwords_cze_mlpe_audioonly_8ch20db_5958_v1_km_km.mov</manifest:ContainerLocation> 

      </manifest:ContainerReference> 

    </manifest:Audio> 
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5.3 Frozen 

The following Frozen example shows audio, video and subtitle.  As an additional feature, 

Type is included for all.  This makes it very clear what it delivered.  As noted above, there is no 

need for @dubbed because the feature is animated.  It would have been nice to include Picture 

data. 

  <manifest:Audio AudioTrackID="md:audtrackid:mpm:750000029502:google.frozen.th.primary.audio.sk.8ch"> 

   <md:Type>primary</md:Type> 

   <md:Language>sk</md:Language> 

   <manifest:ContainerReference> 

    <manifest:ContainerLocation> 

file://resources/Frozen_TH_2398_Google_SLK_DUB_8ch_audio.mov</manifest:ContainerLocation> 

   </manifest:ContainerReference> 

  </manifest:Audio> 

   <!-- Dub Card --> 

  <manifest:Video VideoTrackID="md:vidtrackid:mpm:750000029502:google.frozen.th.dubcard.sk.224"> 

   <md:Type>primary</md:Type> 

   <md:Picture/> 

   <manifest:ContainerReference> 

    <manifest:ContainerLocation>file://resources/Frozen_TH_2398_Google_SLK_DUB-

Cards.mov</manifest:ContainerLocation> 

   </manifest:ContainerReference> 

  </manifest:Video>   

  <!-- Promotional Content --> 

  <manifest:Video VideoTrackID="md:vidtrackid:mpm:750000029502:google.frozen.all.promotion.video.sk.clipdub"> 

   <md:Type>primary</md:Type> 

   <md:Picture/> 

   <manifest:ContainerReference> 

    <manifest:ContainerLocation> 

file://resources/Frozen_TH_1080p2398_224_Google_SLK_DUB_8ch_trlr.mov</manifest:ContainerLocation> 

   </manifest:ContainerReference> 

  </manifest:Video> 

  <!-- Timed Text --> 

  <manifest:Subtitle SubtitleTrackID="md:subtrackid:mpm:750000029502:google.frozen.th.sk.narrative"> 

   <md:Format>SRT</md:Format> 

   <md:Type>normal</md:Type> 

   <md:Language>sk</md:Language> 

   <manifest:ContainerReference> 

    <manifest:ContainerLocation>file://resources/Frozen_TH_2398_Google_SLK_NTT.srt</manifest:ContainerLocation> 

   </manifest:ContainerReference> 

  </manifest:Subtitle> 

  </manifest:Inventory> 
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6 OTHER ELEMENTS 

6.1 Compatibility 

The combination of the schema namespace and the Compatibility element ensures that 

the recipient knows how the manifest was encoded.  In these examples, the namespace is 
http://www.movielabs.com/schema/manifest/v1.1/manifest.   

 <manifest:Compatibility> 

  <manifest:SpecVersion>1.1</manifest:SpecVersion> 

 </manifest:Compatibility> 

or 

 <manifest:Compatibility> 

  <manifest:SpecVersion>1.1a</manifest:SpecVersion> 

 </manifest:Compatibility> 

 

 


